Email delivery service delays
Incident Report for Workato SG
Resolved
After further monitoring, this incident is now considered resolved. The Email by Workato connector is delivering emails as expected and has cleared the backlog of undelivered emails. Customers may have observed that emails sent from the Workato domain, such as error notifications, team invitations, and password reset emails, were delayed or sent out of order. If you continue to experience any mail delivery issues, please contact Workato Support at support.workato.com.
Posted Apr 14, 2024 - 23:08 UTC
Monitoring
Our team has taken steps to remediate the incident and is seeing improvement. We are continuing to monitor for any additional impact.
Posted Apr 14, 2024 - 22:46 UTC
Investigating
We are currently investigating an issue affecting the delivery of emails sent by the Email by Workato connector. We will provide additional information as soon as it becomes available.
Posted Apr 14, 2024 - 22:40 UTC
This incident affected: Email notifications.