Workato Insights performance degradation

Incident Report for Workato SG

Resolved

After further monitoring, this issue is now considered resolved. If you continue to experience any issues, please contact Workato Support at support.workato.com.
Posted Jul 04, 2025 - 04:56 UTC

Monitoring

We identified the root cause of the issue impacting Workato Insights and have implemented remediation steps. Customers who previously experienced 500 errors or delays when accessing the Insights Dashboard should now see improvements. We are actively monitoring the platform to ensure continued stability.
Posted Jul 04, 2025 - 04:37 UTC
This incident affected: Website.